segunda-feira, 3 de março de 2008

2ª LISTA DE EXERCÍCIOS DE ALGORITMOS

Exercícios de Algoritmo Resolvidos.
O post ficou comprido e bem desorganizado, a próxima lista de exercícios vai ser para baixar.

LISTA DE EXERCÍCIOS – N° 2

1) Faça um algoritmo que mostre o novo preço de um produto sabendo-se que este terá um desconto de 15%, mostrando também a classificação do produto segundo o quadro abaixo.



ALGORITMO 1

DECLARE preco, preco_final NUMERICO

ESCREVA “Insira o preço do produto”

LEIA preco

desconto <- preco - (15*preco/100)

SE preco_final >= 500 ENTAO

ESCREVA “O preço do produto é ”, preco, “. Está caro”

SENAO

ESCREVA “O preço do produto é ”, preco, “. Está barato”

FIM_SENAO

FIM_ALGORITMO

2) Uma empresa decide dar um aumento de 30% aos funcionários com salários inferiores a R$ 500,00. Faça um algoritmo que receba o salário do funcionário e mostre o valor do salário reajustado ou uma mensagem caso o funcionário não tenha direito ao aumento.

ALGORITMO 2

DECLARE salario, salario2 NUMERICO

ESCREVA “Insira o valor do salário”

LEIA salario

SE salario < 500 ENTAO

salario2<- salario+(salario*30/100)

ESCREVA “Você vai receber ”, salario2.” reais.”

SENAO

ESCREVA “Você não tem direito a reajuste de salário vai receber ”, salario, .” reais.”

FIM_SENAO

FIM_ALGORITMO

3) Faça um algoritmo que receba o salário de um funcionário, calcule e mostre o novo salário deste funcionário, acrescido de bonificação e de auxilio escola.


ALGORITMO 3

DECLARE salario, salario2, salario3 NUMERICO

ESCREVA “Insira o valor do salário”

LEIA salario

SE salario <=500 ENTAO

salario2<- salario+(salario*5/100)

ESCREVA “Você vai receber ”, salario2.” reais.”

SENAO

salario2<- salario+(salario*12/100)

ESCREVA “Você vai receber ”, salario2.” reais.”

FIM_SENAO

SE salario <= 600 ENTAO

salario3<-salario2+150

SENAO

salario3<-salario2+100

FIM_SENAO

ESCREVA "Seu salário com todos os reajuste é de ",salario3

FIM_ALGORITMO

4) Faça um algoritmo que receba o valor do salário mínimo, o número de horas trabalhadas, o número de dependentes do funcionário e a quantidade horas extras trabalhadas. Calcule e mostre o salário a receber do funcionário seguindo as regras abaixo.

  • o valor da hora trabalhada é igual a 1/5 do salário mínimo;

  • o salário do mês é igual ao número de horas trabalhadas vezes o valor da hora trabalhada;

  • para cada dependente acrescentar 32 reais;

  • para cada hora extra trabalhada calcular o valor da hora trabalhada acrescida de 50%;

  • o salário bruto é igual ao salário do mês mais o valor dos dependentes mais o valor das horas extras;

  • calcular o valor do imposto de renda retido na fonte seguindo a tabela abaixo.

  • o salário líquido é igual ao salário bruto menos IRRF
  • a gratificação segue a tabela abaixo.

  • o salário a receber do funcionário é igual ao salário líquido mais a gratificação.

ALGORITMO 4

DECLARE sm, ht, df, qr, vr, salm, sald, sale, salb,sall,salr NUMERICO

//sm = salario minimo

//ht = horas trabalhadas

//df = dependentes do funcionario

//qr = quantidades de horas extras trabalhadas

//vr = valor de horas trabalhadas

//salm = salario do mes

//sald = salario com os dependentes

//sald = salario das horas extras

//salb = salario bruto

//sall = salario liquido

//salr = salario a receber

ESCREVA "Insira o salario minimo"

LEIA sm

ESCREVA "Insira o numero de horas trabalhadas"

LEIA ht

ESCREVA "Insira o numero de dependentes do funcionario"

LEIA df

ESCREVA "Inira a quantidade de horas extras"

LEIA qr

//o valor da hora trabalhada é igual a 1/5 do salário mínimo;

vr<-sm/5

//o salário do mês é igual ao número de horas trabalhadas vezes o valor da hora trabalhada

salm<-ht*vr

//para cada dependente acrescentar 32 reais

sald<-df*32

//para cada hora extra trabalhada calcular o valor da hora trabalhada acrescida de 50%

sale<-(vr+vr*50/100)*qr

//o salário bruto é igual ao salário do mês mais o valor dos dependentes mais o valor das horas extras

salb<-salm+sald+sale

SE salb > 200 ENTAO

//o salário líquido é igual ao salário bruto menos IRRF

sall <- salb - salb*10/100

FIM-SE

//o salário a receber do funcionário é igual ao salário líquido mais a gratificação

SE sall <= 350 ENTAO

salr<-sall + 100

SENAO

salr<-sall + 50

FIM-SENAO

ESCREVE "O Funcionario ira receber ",salr," de salario"

FIM_ALGORITMO

5) Uma agência bancária possui dois tipos de investimentos, conforme o quadro abaixo. Faça um algoritmo que receba o tipo do investimento e o valor do investimento, calcule e mostre o valor corrigido de acordo com o tipo de investimento.


ALGORITMO 5
DECLARE investimento LITERAL
calculo, valor NUMERICO
Escreva "Qual o seu investimento: poupança ou fundos de reda fixa?"
LEIA investimento
ESCREVA "Qual o valor do investimento"
LEIA valor
SE investimento="poupança" ENTAO
calculo<- valor+(valor*3/100) SENAO SE investimento="fundos de reda fixa" ENTAO calculo<- valor+(valor*4/100) SENAO ESCREVA "Você não escolheu nenhuma das opções" FIM-SENAO ESCREVA "Valor do investimento corrigido é de ",calculo FIM_ALGORITMO

6) Faça um algoritmo que receba a altura e o sexo de uma pessoa, calcule e mostre o seu peso ideal, utilizando as seguintes fórmulas:

- para homens: (72.7 * h) - 58;
- para mulheres: (62.1 * h) - 44.7

ALGORITMO 6
DECLARE peso, calculo NUMERICO
sexo LITERAL
ESCREVA “Insira seu peso”
LEIA peso
Escreva "Você é homem ou mulher?"
LEIA sexo
SE sexo="mulher" ENTAO
calculo<- (72.7*peso)-58

SENAO

calculo<- (62.1*peso)-44.7

FIM_SENAO

ESCREVA "Seu peso ideial é de ",calculo

FIM_ALGORITMO


11 comentários:

Fellipe Alexandre disse...

Vlw ai cara!!!
Estava precisando disso mesmo!!!

Vlw Mesmo!!!

Bom Trabalho!!!

T+

Anônimo disse...

muito bom heim!!!
pode postar mais se quiser, ajudando muito11
;)

wanderleya23 disse...

existe alguma forma mais pratica de aprender algoritimo?

Anônimo disse...

Tem um monte de erro ai

Igor disse...

Pessoal, no site da CBCT tem simulados de algoritmo e lógica de programação. O site é www.cbct.com.br

"RONALDO" disse...

Ou no algoritimo 6 tem um erro ai tem não, na hora do calculo

Juliana disse...

poo valeu, deu maior ajuda aqui

Herik disse...

programa 6 corrigido

6) Faça um algoritmo que receba a altura e o sexo de uma pessoa, calcule e mostre o seu peso ideal, utilizando as seguintes fórmulas:

- para homens: (72.7 * h) - 58;
- para mulheres: (62.1 * h) - 44.7

ALGORITMO 6
DECLARE altura, peso_ideal NUMERICO
sexo LITERAL
ESCREVA “Insira sua altura”
LEIA altura
Escreva "Você é homem ou mulher?"
LEIA sexo
SE sexo="mulher" ENTAO
peso_ideal <- (62.1*altura)-44.7

SENAO


peso_ideal <- (72.7*altura)-58

FIM_SENAO


ESCREVA "Seu peso ideial é de ",peso_ideal


FIM_ALGORITMO

Pathy Nina disse...

oi preciso de uma ajuda pra fazer uns algoritmos sera q poderiamos trocar email? patricianina@hotmail.com
grata!

Anônimo disse...

muito bom

lucinha disse...

Gostaria de alguém me ajudasse a resolver esse algoritmo
Elabore um algoritmo onde o cidadao possa escolher em qual enquete deseja votar:
a) Quanto você acha que sabe o que significa as siglas dos impostos que você paga?
30% 70%
50% 100%
b) Quanto você entende sobre as leis que um cidadao não pode transgredir?
30% 70%
50% 100%